Setting Up Dynamic DNS For Your Domain

zeadmin

Administrator
Staff member
#1
Things To Know:
  • The new platform should be backward compatible with the old ZoneEdit dynamic DNS clients. If you were using it before the acquisition it should still work now. Post a bug report if this is not the case.
  • You can still use your username/password for dynamic DNS but we strongly recommend using the AUTH token. When you do that, you enable AUTH tokens in the dynamic DNS section for your domain, and simply replace your password with the auth token.
 
#3
Hi, why there are only sub-domains for example: home.example.com, I don't want to use sub domain, i want main domain example.com. Could you explain about the Domain record file, where to find it? I registered domain with Godaddy
I have watched many tutorial video to setup home sever for dynamic ip, Dyndns, Noip.... They are all using sub domain, or some strange domain these companies provide. I don't want that, i want to point my domain from Godaddy to my dynamic ip pc at home, please do a tutorial video about it if it is possible
Thank you
 

sandy neal

Administrator
Staff member
#4
Hi there

To set a dynamic update for the root domain enter the @ sign in the host text box when creating a dynamic record,

thanks
sandy
 
#5
Hi All,
I'm the owner of a domain and managed to set it up with a DYNamic record by typing in the IP manually and it's working fine, but I am unable to update the IP dynamically neither via the Javascript client showcased on your site nor via my Synology NAS server. I'm getting the response: <ERROR CODE="709" TEXT="Invalid hostname: www.xyxyxyxy.com" ZONE="www.xyxyxyxy.com">
I have attached some screenshots of my settings, what am I missing? Your help is greatly appreciated.

Thanks,
Norbert
DNS.JPG DynDNS_Updater.JPG
 
#6
Hi
I have exactly the same problem...
More than that: If I intentionally specify a wrong password, I still get the error message ERROR CODE="709" TEXT="Invalid hostname: www.xxxxxxx.ch" ZONE="www.xxxxxxx.ch"> !!!
In this case, I was expecting a message like: "Wrong password ".

Can anybody help? Thanks, Lukas
 
#8
Hi,

I'm trying to use the JavaScript DynDNS updater, and I'm not getting a response message at all, and my IP isn't updating.

I press Start and Client Status says ON (even for a one time update) but nothing happens. I've tried it in Chrome (latest) and Edge. I've looked in the JavaScript console and I'm not getting any error messages.
The settings I'm using are:
Username: <as per login>
Password: I've tried the Auth token, and my login password
Hostname: I've tried @ and my hostname
Update wildcard: I've tried no and yes

Thanks for any suggestions.
 

sandy neal

Administrator
Staff member
#11
hmm the zone seems fine... please send in the command line being used or the router config and I wil see what I can do... omit and password and user ID info,.....

thanks
sandy
 
#14
No problems. It still wasn't working for me, however my router firmware updated and that's now automatically doing it like it used to, which is a better outcome for me! Thanks :)
 
#17
I tried to use dynamic DNS with my domain.
I tried several methods to update the IP (DynDNS of Router (O2 HomeBox 2), ddclient, script from this forum, javascript dynamic dns client for zoneedit) without success.
I always get
<ERROR CODE="709" TEXT="Invalid hostname: yyy.xxx.de" ZONE="yyy.xxx.de">
I tried with and without subdomaine.
I followed the directions in the videos for the setup.
Any suggestions appreciated
Tom
 

le_

New Member
#19
Unfortunately Javascript Client does not work. No reply is given.
The use of this URL also does not help to update the IP: le_:My_DYN_Authentication_Token@dynamic.zoneedit.com/dyn/jsclient.php?rsp_ident=zoneedit&hostname=le-home.tk&wildcard=no
(response in this case: <ERROR CODE="709" TEXT="Invalid hostname: " ZONE="">)
 
Last edited:
#20
I haven't manage to get my Synology Router to update the Zoneedit dynamic IP. Some help would be most appreciated. Further, as Synology devices are fairly popular, you may miss out on dynamic DNS users you potentially could up-sell, i.e., fixing it would benefit not only me.

Me


Router
Synology RT1900ac sw version SRM 1.1.2-6425 Update 1(similar code is running in Synology disk stations DSM).
Synology devices are shipped with built in, preconfigured support for Zoneedit. A http request is constructed based on username, password, domain entered in a dialog, eventually ending up in a request like: "_http_://dynamic.zoneedit.com/auth/dynamic.html?host=ddm.se&dnsto=217.211.14.244" being sent (authentication via http-basic-authentication).

Troubleshooting done
In an effort to diagnose the problem, sending this above GET request from my Chrome browser (providing credentials (dynamic auth.)), an error message is returned, and the IP address is not updated.
<ERROR CODE="709" TEXT="Invalid hostname: ddm.se" ZONE="ddm.se">

Any advice would be most appreciated
Best regards
/PerJ
 
Top