Explanation needed for wget response

Mel Smith

New Member
Hi All:

MY first post.

I use port forwarding to forward the port 4296 to my Apache 2.2 server.
This has worked without fail for nine years.

Then suddenly (after two events with my ISP Shawcable.net in Edmonton), my
Apache server (which 'listens on port 4296) now no longer responds to visits.
Shaw had changed my external IP from 96.52.38.31 to 96.52.51.37.
They 'said' my services were *not* affected ???

I can use http://127.0.0.1:4296 on my laptop server with NO Problem.

However, I (and my small set of users) get the error below when trying to visit my site.

I use a Linksys EA3500 router, and also a ASUS RT-AC1200G Dual Band Wirded/wireless router.
I have tested access under both routers on Win 7 and Win 10 machines, and I get the
same error:
ERR_CONNECTION REFUSED

So, I asked ZONEEDIT for support, and I now show Chris Cherry's quick response below.

Hope someone here can help me debug further to see what is happening.
I'm in desperate straits :(

-Mel Smith
www.mesaeastpark.com


****** Last Part of Chris Cherry's response to me on my error [#106292] *****
WGET command shows the server is rejecting the connections (I assume it's not watching on port 80):

:~$ wget ww2.mesaeastpark.com
--2019-10-26 20:40:09-- http://ww2.mesaeastpark.com/
Resolving ww2.mesaeastpark.com (ww2.mesaeastpark.com)... 96.52.51.37
Connecting to ww2.mesaeastpark.com (ww2.mesaeastpark.com)|96.52.51.37|:80... failed: Connection refused.

**** This *next below* is my real problem -- What does it mean, and why is it timing out ?
**** and who/what is failing. Apache shows *nothing* in the logs ??

~$ wget ww2.mesaeastpark.com:4296
--2019-10-26 20:47:54-- http://ww2.mesaeastpark.com:4296/
Resolving ww2.mesaeastpark.com (ww2.mesaeastpark.com)... 96.52.51.37
Connecting to ww2.mesaeastpark.com (ww2.mesaeastpark.com)|96.52.51.37|:4296... failed: Connection timed out.
Retrying.
**********
 

Mel Smith

New Member
Hi All:
I guess I posted four years ago, and forgot that I did so.
So, I'm not a *new* member. I just forgot . Sorry

But I still need some help to understand what program/machine/procedure actually 'refused' to connect

Thanks for any help offered
 

Mel Smith

New Member
Hi Chris:
I reviewed all my configs on my Linksys EA3500 router. Did diagnostics, and set Logs *on* for that router.
Also, confirmed that Windows Defender was *disabled* on my Win 7 Laptop server (via services on Control Panel).
Then tried again to visit http://ww2.mesaeastpark.com:4296

Result: Same as before : ERR_CONNECTION REFUSED
and: Not a hint in my router logs of any outside visit attempt.

So, I guess shaw.ca has blocked the port, when I requested winter suspension last Wednesday.
Of course, talks with them resulted in a run-around, and with them saying they cannot support anyone who residential servers.

But, when I set up my system in Mesa, Arizona next Tuesday morning using COX.NET as my ISP, and when I log in to zoneedit then with a new external IP Address to change my setup, *then* I'll know. If I can get online, it means Shaw was blocking me here in St Albert, Alberta.

Thanks very for your attention and responses both here and thru support. Zonedit is a great company with great people !

-Mel Smith
www.mesaeastpark.com
www.whosaway.com
 

Chris Cherry

Mr. Happy To Help You.
You're welcome, Mel! Do let myself and our forum readers know if that was the cause.
 

Mel Smith

New Member
Hi Chris Cherry and all who followed this latest thread of mine:

I'm down in Arizona now, and have just installed my server and development machines.

Everything works FINE now using COX.NET as my ISP.

I, of course, got a new IP Address from COX, Then visited and logged in at zoneedit.com. Then edited my new IP Address, and, within five minutes I got back online. easily and quickly

So, basically, I got 'screwed' by Shaw, and will be addressing this issue with them next Spring when I return to Canada.

Again, a big Thank You to Chris Cherry for sticking with me on this issue !

-Mel Smith
mesaeastpark.com
whosaway.com
 

Chris Cherry

Mr. Happy To Help You.
You're welcome, Mel, and thanks for the update. Have a pleasant (warm) stay in Arizona, and we'll see you again next spring :)
 
Top