Dynamic DNS not updating

Rixon

New Member
My router (BT Smart Hub Type A - also known as HomeHub 6) includes a ddns client that was working, but now I just keep getting the very unhelpful error message in my router logs
Code:
pp1:DDNS ERROR!!client:1 DynDNS update server error. Retry in 30 min.
I was originally using my account password but I've swapped the password auth with the token auth, and there has been no change in behaviour.

On the zoneedit site, I can't seem to find any information at all about why the requests are getting 'update server error', the page at User > Security > Activity Logs is completely empty even though I am sure there should be some activity, is that a paid feature? The router does not tell me what the error is or show me the response body so how can I find out what's going wrong? When I log in to the zoneedit site I see that one of the two hosts it should be updating has been successfully updated, but the other has not. I can't find anywhere on the zoneedit site where I can verify when or how that was updated.

Why are the activity logs always empty and how can I find out what the error is?
 

sandy neal

Administrator
Staff member
hi there on the zoneedit page the security options. .. there is no Activity Logs option.. is that on your router?

what is the domain name of concern?

regards
 

sandy neal

Administrator
Staff member
ahh yes sorry that one is preference enabled.. once enabled it will list logs selected in the Activity Notifications section but i do see that it does not seem to be operational presently I have opened a dev ticket on that... that said it would list DNS updates but would not specify if dynamic or not. on your current zone file can you please change the TTL on dynamic records to be no less then 10 minutes or 600 seconds... can you send in a screen grab of your router config for dyn updates.

regards.
 

Rixon

New Member
Setting the TTL that high kind of goes against the point of using dynamic DNS, and doesn't sound like it would have anything to do with 'server error' when the router requests the update. I've done it anyway but it hasn't changed the behaviour.
 

Attachments

sandy neal

Administrator
Staff member
I have the most recent logs available now:

it looks fine actually:

Aug 28 13:44:36 dyn01-zpc zoneedit: /var/www/dynamic.zoneed <-@86.177.242.159> setting 35uu.cf to 86.177.242.159 Aug 28 13:44:36 dyn01-zpc zoneedit: /var/www/dynamic.zoneed <-@86.177.242.159> Added 3 new DYN records for 35uu.cf (0 errors, 0 duplicates skipped) Aug 28 13:44:36 dyn01-zpc zoneedit: /var/www/dynamic.zoneed <-@86.177.242.159> Update of 35uu.cf [type=DYN] took 0.01 seconds.

Aug 28 19:44:43 dyn01-zpc zoneedit: /var/www/dynamic.zoneed <-@86.177.242.159> 35uu.cf already set to 86.177.242.159 Aug 28 19:44:43 dyn01-zpc zoneedit: /var/www/dynamic.zoneed <-@86.177.242.159> Looking up base domain for 35uu.cf
 

Rixon

New Member
yes, but again there is nothing in that log entry about cloud.35uu.cf, only 35uu.cf, and my router logs has the same error again, and the ip for cloud. was not updated.
 

Rixon

New Member
also your log doesn't seem to be correct - it says it made 3 new DYN records and had 0 errors, but I'm only trying to set 2 records and only one is succeeding, and my router reports 'server error'
 

sandy neal

Administrator
Staff member
first off .. activity logs now works :)


and...
=we see no attempt to update cloud.35uu.cf. It's never even tried, so there's no error for us to go on... no logs available
Please delete the root record in the router, and disable the "Use multiple hosts" option, and just set cloud.35uu.cf to see if it updates. Then re-enable the multiple hosts, and add the root.

regards
 

Rixon

New Member
we see no attempt to update cloud.35uu.cf. It's never even tried, so there's no error for us to go on... no logs available
OK this sounds like my router must be firing off both requests separately and too close together and a firewall (at your end? or somewhere between us?) is ratelimiting or something (which seems odd for 2 requests, when most rate limiters default to >=3 requests within a minute), because my router is claiming the request is failing with a server error. By doing what you suggest there, the IP for cloud. will update on the next 30min mark but then adding the root domain after it will just end up with the same problem in reverse, cloud. will update but @ will not.
 
Top